Hudson error: could not delete ..config.xml

How updating Hudson plugins resolved a config.xml deletion error that appeared after upgrading the Hudson CI server and changing job configurations.

Today we updated our Hudson CI-server. After changing job-configuration Hudson throws an error, that the config.xml could not be deleted.

But the new entries are correct saved.

Nevertheless such behavior bothers.

The trick was to update also the plugins. After that all works fine again.