SQL Server 2005 Zugriffsproblem bei Remotezugriff
Wie man fehlgeschlagene Remote-Verbindungen zu SQL Server 2005 behabt, indem TCP/IP und Named Pipes über die Surface Area Configuration aktiviert werden.
Wenn ein Remote-Zugriff auf einen SQL Server 2005 mit der Fehlermeldung
"A connection was successfully established with the server, but then an error occurred during the pre-login handshake.
When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections."
scheitert, dann hilft folgendes
- Öffnen der SQL Server Surface Area Configuration
- Anwählen von Surface Area Configuration for Services and Connections
Unter MSSQLSERVER > Database Engine > Remote den Zugriff auf Local and remote connections mit Unterpunkt Using both TCP/IP and named pipes setzen - SQL Server neu starten